summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/static-pie/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make/static-pie/Makefile')
-rw-r--r--src/test/run-make/static-pie/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/test/run-make/static-pie/Makefile b/src/test/run-make/static-pie/Makefile
new file mode 100644
index 000000000..945ec1724
--- /dev/null
+++ b/src/test/run-make/static-pie/Makefile
@@ -0,0 +1,18 @@
+-include ../../run-make-fulldeps/tools.mk
+
+# only-x86_64
+# only-linux
+# ignore-gnux32
+
+# How to manually run this
+# $ ./x.py test --target x86_64-unknown-linux-[musl,gnu] src/test/run-make/static-pie
+
+all: test-clang test-gcc
+
+test-%:
+ if ./check_$*_version.sh; then\
+ ${RUSTC} -Clinker=$* -Clinker-flavor=gcc --target ${TARGET} -C target-feature=+crt-static test-aslr.rs; \
+ ! readelf -l $(call RUN_BINFILE,test-aslr) | $(CGREP) INTERP; \
+ readelf -l $(call RUN_BINFILE,test-aslr) | $(CGREP) DYNAMIC; \
+ $(call RUN,test-aslr) --test-aslr; \
+ fi