summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/static-pie
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/test/run-make/static-pie/Makefile18
-rwxr-xr-xtests/run-make/static-pie/check_clang_version.sh (renamed from src/test/run-make/static-pie/check_clang_version.sh)0
-rwxr-xr-xtests/run-make/static-pie/check_gcc_version.sh (renamed from src/test/run-make/static-pie/check_gcc_version.sh)0
-rw-r--r--tests/run-make/static-pie/test-aslr.rs (renamed from src/test/run-make/static-pie/test-aslr.rs)0
4 files changed, 0 insertions, 18 deletions
diff --git a/src/test/run-make/static-pie/Makefile b/src/test/run-make/static-pie/Makefile
deleted file mode 100644
index e71770636..000000000
--- a/src/test/run-make/static-pie/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# only-x86_64
-# only-linux
-# ignore-gnux32
-
-# How to manually run this
-# $ ./x.py test --target x86_64-unknown-linux-[musl,gnu] src/test/run-make/static-pie
-
-all: test-clang test-gcc
-
-test-%:
- if ./check_$*_version.sh; then\
- ${RUSTC} -Clinker=$* -Clinker-flavor=gcc --target ${TARGET} -C target-feature=+crt-static test-aslr.rs; \
- ! readelf -l $(call RUN_BINFILE,test-aslr) | $(CGREP) INTERP; \
- readelf -l $(call RUN_BINFILE,test-aslr) | $(CGREP) DYNAMIC; \
- $(call RUN,test-aslr) --test-aslr; \
- fi
diff --git a/src/test/run-make/static-pie/check_clang_version.sh b/tests/run-make/static-pie/check_clang_version.sh
index b8e97c3da..b8e97c3da 100755
--- a/src/test/run-make/static-pie/check_clang_version.sh
+++ b/tests/run-make/static-pie/check_clang_version.sh
diff --git a/src/test/run-make/static-pie/check_gcc_version.sh b/tests/run-make/static-pie/check_gcc_version.sh
index d07e1d151..d07e1d151 100755
--- a/src/test/run-make/static-pie/check_gcc_version.sh
+++ b/tests/run-make/static-pie/check_gcc_version.sh
diff --git a/src/test/run-make/static-pie/test-aslr.rs b/tests/run-make/static-pie/test-aslr.rs
index 96b17af46..96b17af46 100644
--- a/src/test/run-make/static-pie/test-aslr.rs
+++ b/tests/run-make/static-pie/test-aslr.rs