summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/thumb-none-qemu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make/thumb-none-qemu/Makefile')
-rw-r--r--src/test/run-make/thumb-none-qemu/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/test/run-make/thumb-none-qemu/Makefile b/src/test/run-make/thumb-none-qemu/Makefile
new file mode 100644
index 000000000..ab8b90e15
--- /dev/null
+++ b/src/test/run-make/thumb-none-qemu/Makefile
@@ -0,0 +1,27 @@
+-include ../../run-make-fulldeps/tools.mk
+
+# only-thumb
+
+# How to run this
+# $ ./x.py clean
+# $ ./x.py test --target thumbv7m-none-eabi src/test/run-make
+
+# For cargo setting
+export RUSTC := $(RUSTC_ORIGINAL)
+export LD_LIBRARY_PATH := $(HOST_RPATH_DIR)
+# We need to be outside of 'src' dir in order to run cargo
+export WORK_DIR := $(TMPDIR)
+export HERE := $(shell pwd)
+
+## clean up unused env variables which might cause harm.
+unexport RUSTC_LINKER
+unexport RUSTC_BOOTSTRAP
+unexport RUST_BUILD_STAGE
+unexport RUST_TEST_THREADS
+unexport RUST_TEST_TMPDIR
+unexport AR
+unexport CC
+unexport CXX
+
+all:
+ bash script.sh