summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/track-path-dep-info/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make/track-path-dep-info/Makefile')
-rw-r--r--src/test/run-make/track-path-dep-info/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/test/run-make/track-path-dep-info/Makefile b/src/test/run-make/track-path-dep-info/Makefile
new file mode 100644
index 000000000..465d37447
--- /dev/null
+++ b/src/test/run-make/track-path-dep-info/Makefile
@@ -0,0 +1,13 @@
+-include ../../run-make-fulldeps/tools.mk
+
+# FIXME(eddyb) provide `HOST_RUSTC` and `TARGET_RUSTC`
+# instead of hardcoding them everywhere they're needed.
+ifeq ($(IS_MUSL_HOST),1)
+ADDITIONAL_ARGS := $(RUSTFLAGS)
+endif
+
+all:
+ # Proc macro
+ $(BARE_RUSTC) $(ADDITIONAL_ARGS) --out-dir $(TMPDIR) macro_def.rs
+ EXISTING_PROC_MACRO_ENV=1 $(RUSTC) --emit dep-info macro_use.rs
+ $(CGREP) "emojis.txt:" < $(TMPDIR)/macro_use.d