summaryrefslogtreecommitdiffstats
path: root/src/test/ui/feature-gates/rustc-private.stderr
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/ui/feature-gates/rustc-private.stderr')
-rw-r--r--src/test/ui/feature-gates/rustc-private.stderr12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/test/ui/feature-gates/rustc-private.stderr b/src/test/ui/feature-gates/rustc-private.stderr
new file mode 100644
index 000000000..1a8536d37
--- /dev/null
+++ b/src/test/ui/feature-gates/rustc-private.stderr
@@ -0,0 +1,12 @@
+error[E0658]: use of unstable library feature 'rustc_private': this crate is being loaded from the sysroot, an unstable location; did you mean to load this crate from crates.io via `Cargo.toml` instead?
+ --> $DIR/rustc-private.rs:3:1
+ |
+LL | extern crate libc;
+ | ^^^^^^^^^^^^^^^^^^
+ |
+ = note: see issue #27812 <https://github.com/rust-lang/rust/issues/27812> for more information
+ = help: add `#![feature(rustc_private)]` to the crate attributes to enable
+
+error: aborting due to previous error
+
+For more information about this error, try `rustc --explain E0658`.