summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/Cargo.toml')
-rw-r--r--src/tools/cargo/Cargo.toml119
1 files changed, 119 insertions, 0 deletions
diff --git a/src/tools/cargo/Cargo.toml b/src/tools/cargo/Cargo.toml
new file mode 100644
index 000000000..56c9827cb
--- /dev/null
+++ b/src/tools/cargo/Cargo.toml
@@ -0,0 +1,119 @@
+[package]
+name = "cargo"
+version = "0.71.0"
+edition = "2021"
+license = "MIT OR Apache-2.0"
+homepage = "https://crates.io"
+repository = "https://github.com/rust-lang/cargo"
+documentation = "https://docs.rs/cargo"
+readme = "README.md"
+description = """
+Cargo, a package manager for Rust.
+"""
+
+[lib]
+name = "cargo"
+path = "src/cargo/lib.rs"
+
+[dependencies]
+anyhow = "1.0.47"
+base64 = "0.21.0"
+bytesize = "1.0"
+cargo-platform = { path = "crates/cargo-platform", version = "0.1.2" }
+cargo-util = { path = "crates/cargo-util", version = "0.2.4" }
+clap = "4.2.0"
+crates-io = { path = "crates/crates-io", version = "0.36.0" }
+curl = { version = "0.4.44", features = ["http2"] }
+curl-sys = "0.4.61"
+env_logger = "0.10.0"
+filetime = "0.2.9"
+flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
+git2 = "0.17.0"
+git2-curl = "0.18.0"
+gix = { version = "0.39.0", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
+gix-features-for-configuration-only = { version = "0.28.0", package = "gix-features", features = [ "parallel" ] }
+glob = "0.3.0"
+hex = "0.4"
+hmac = "0.12.1"
+home = "0.5"
+http-auth = { version = "0.1.6", default-features = false }
+humantime = "2.0.0"
+ignore = "0.4.7"
+im-rc = "15.0.0"
+indexmap = "1"
+is-terminal = "0.4.4"
+itertools = "0.10.0"
+jobserver = "0.1.26"
+lazy_static = "1.2.0"
+lazycell = "1.2.0"
+libc = "0.2"
+libgit2-sys = "0.15.0"
+log = "0.4.6"
+memchr = "2.1.3"
+opener = "0.5"
+openssl = { version = '0.10.11', optional = true }
+os_info = "3.5.0"
+pasetors = { version = "0.6.4", features = ["v3", "paserk", "std", "serde"] }
+pathdiff = "0.2"
+pretty_env_logger = { version = "0.4", optional = true }
+rand = "0.8.5"
+rustfix = "0.6.0"
+semver = { version = "1.0.3", features = ["serde"] }
+serde = { version = "1.0.123", features = ["derive"] }
+serde-value = "0.7.0"
+serde_ignored = "0.1.0"
+serde_json = { version = "1.0.30", features = ["raw_value"] }
+sha1 = "0.10.5"
+shell-escape = "0.1.4"
+strip-ansi-escapes = "0.1.0"
+tar = { version = "0.4.38", default-features = false }
+tempfile = "3.0"
+termcolor = "1.1"
+time = { version = "0.3", features = ["parsing", "formatting"]}
+toml = "0.7.0"
+toml_edit = "0.19.0"
+unicode-width = "0.1.5"
+unicode-xid = "0.2.0"
+url = "2.2.2"
+walkdir = "2.2"
+
+# A noop dependency that changes in the Rust repository, it's a bit of a hack.
+# See the `src/tools/rustc-workspace-hack/README.md` file in `rust-lang/rust`
+# for more information.
+rustc-workspace-hack = "1.0.0"
+
+[target.'cfg(windows)'.dependencies]
+fwdansi = "1.1.0"
+
+[target.'cfg(windows)'.dependencies.windows-sys]
+version = "0.45"
+features = [
+ "Win32_Foundation",
+ "Win32_Storage_FileSystem",
+ "Win32_System_Console",
+ "Win32_System_IO",
+ "Win32_System_Threading",
+ "Win32_System_JobObjects",
+ "Win32_Security",
+ "Win32_System_SystemServices"
+]
+
+[dev-dependencies]
+cargo-test-macro = { path = "crates/cargo-test-macro" }
+cargo-test-support = { path = "crates/cargo-test-support" }
+same-file = "1.0.6"
+snapbox = { version = "0.4.0", features = ["diff", "path"] }
+
+[build-dependencies]
+flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
+tar = { version = "0.4.38", default-features = false }
+
+[[bin]]
+name = "cargo"
+test = false
+doc = false
+
+[features]
+vendored-openssl = ["openssl/vendored"]
+vendored-libgit2 = ["libgit2-sys/vendored"]
+pretty-env-logger = ["pretty_env_logger"]