summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/Cargo.toml')
-rw-r--r--src/tools/cargo/Cargo.toml21
1 files changed, 9 insertions, 12 deletions
diff --git a/src/tools/cargo/Cargo.toml b/src/tools/cargo/Cargo.toml
index 05c95c727..7e383be69 100644
--- a/src/tools/cargo/Cargo.toml
+++ b/src/tools/cargo/Cargo.toml
@@ -19,22 +19,22 @@ cargo-credential = { version = "0.2.0", path = "credential/cargo-credential" }
cargo-platform = { path = "crates/cargo-platform", version = "0.1.3" }
cargo-test-macro = { path = "crates/cargo-test-macro" }
cargo-test-support = { path = "crates/cargo-test-support" }
-cargo-util = { version = "0.2.4", path = "crates/cargo-util" }
+cargo-util = { version = "0.2.5", path = "crates/cargo-util" }
cargo_metadata = "0.14.0"
clap = "4.2.0"
core-foundation = { version = "0.9.0", features = ["mac_os_10_7_support"] }
crates-io = { version = "0.37.0", path = "crates/crates-io" }
criterion = { version = "0.3.5", features = ["html_reports"] }
curl = "0.4.44"
-curl-sys = "0.4.61"
+curl-sys = "0.4.63"
env_logger = "0.10.0"
filetime = "0.2.9"
flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
fwdansi = "1.1.0"
git2 = "0.17.1"
git2-curl = "0.18.0"
-gix = { version = "0.44.1", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
-gix-features-for-configuration-only = { version = "0.29.0", package = "gix-features", features = [ "parallel" ] }
+gix = { version = "0.45.1", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
+gix-features-for-configuration-only = { version = "0.30.0", package = "gix-features", features = [ "parallel" ] }
glob = "0.3.0"
handlebars = { version = "3.2.1", features = ["dir_source"] }
hex = "0.4.2"
@@ -45,7 +45,6 @@ humantime = "2.0.0"
ignore = "0.4.7"
im-rc = "15.0.0"
indexmap = "1"
-is-terminal = "0.4.4"
itertools = "0.10.0"
jobserver = "0.1.26"
lazy_static = "1.3.0"
@@ -56,7 +55,7 @@ log = "0.4.17"
memchr = "2.1.3"
miow = "0.5.0"
opener = "0.5"
-openssl ="0.10.50"
+openssl ="0.10.55"
os_info = "3.5.0"
pasetors = { version = "0.6.4", features = ["v3", "paserk", "std", "serde"] }
pathdiff = "0.2"
@@ -80,6 +79,7 @@ sha2 = "0.10.6"
shell-escape = "0.1.4"
snapbox = { version = "0.4.0", features = ["diff", "path"] }
strip-ansi-escapes = "0.1.0"
+syn = { version = "2.0.14", features = ["extra-traits", "full"] }
tar = { version = "0.4.39", default-features = false }
tempfile = "3.1.0"
termcolor = "1.1.2"
@@ -95,7 +95,7 @@ windows-sys = "0.48"
[package]
name = "cargo"
-version = "0.72.1"
+version = "0.73.0"
edition = "2021"
license = "MIT OR Apache-2.0"
homepage = "https://crates.io"
@@ -136,10 +136,8 @@ humantime.workspace = true
ignore.workspace = true
im-rc.workspace = true
indexmap.workspace = true
-is-terminal.workspace = true
itertools.workspace = true
jobserver.workspace = true
-lazy_static.workspace = true
lazycell.workspace = true
libc.workspace = true
libgit2-sys.workspace = true
@@ -150,6 +148,7 @@ os_info.workspace = true
pasetors.workspace = true
pathdiff.workspace = true
pretty_env_logger = { workspace = true, optional = true }
+pulldown-cmark.workspace = true
rand.workspace = true
rustfix.workspace = true
semver.workspace = true
@@ -160,6 +159,7 @@ serde_json = { workspace = true, features = ["raw_value"] }
sha1.workspace = true
shell-escape.workspace = true
strip-ansi-escapes.workspace = true
+syn.workspace = true
tar.workspace = true
tempfile.workspace = true
termcolor.workspace = true
@@ -183,11 +183,8 @@ features = [
"Win32_Foundation",
"Win32_Storage_FileSystem",
"Win32_System_Console",
- "Win32_System_IO",
"Win32_System_Threading",
"Win32_System_JobObjects",
- "Win32_Security",
- "Win32_System_SystemServices"
]
[dev-dependencies]