summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/benches/benchsuite/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/benches/benchsuite/Cargo.toml')
-rw-r--r--src/tools/cargo/benches/benchsuite/Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/tools/cargo/benches/benchsuite/Cargo.toml b/src/tools/cargo/benches/benchsuite/Cargo.toml
new file mode 100644
index 000000000..f4bc3583a
--- /dev/null
+++ b/src/tools/cargo/benches/benchsuite/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "benchsuite"
+version = "0.1.0"
+edition = "2021"
+license = "MIT OR Apache-2.0"
+homepage = "https://github.com/rust-lang/cargo"
+repository = "https://github.com/rust-lang/cargo"
+documentation = "https://docs.rs/cargo-platform"
+description = "Benchmarking suite for Cargo."
+
+[dependencies]
+cargo = { path = "../.." }
+# Consider removing html_reports in 0.4 and switching to `cargo criterion`.
+criterion = { version = "0.3.5", features = ["html_reports"] }
+flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
+tar = { version = "0.4.38", default-features = false }
+url = "2.2.2"
+
+[lib]
+bench = false
+
+[[bench]]
+name = "resolve"
+harness = false
+
+[[bench]]
+name = "workspace_initialization"
+harness = false