summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/ci/fetch-smoke-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/ci/fetch-smoke-test.sh')
-rwxr-xr-xsrc/tools/cargo/ci/fetch-smoke-test.sh27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/tools/cargo/ci/fetch-smoke-test.sh b/src/tools/cargo/ci/fetch-smoke-test.sh
new file mode 100755
index 000000000..17993d1fd
--- /dev/null
+++ b/src/tools/cargo/ci/fetch-smoke-test.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+# This script builds with static curl, and verifies that fetching works.
+
+set -ex
+
+if [[ -z "$RUNNER_TEMP" ]]
+then
+ echo "RUNNER_TEMP must be set"
+ exit 1
+fi
+
+if [ ! -f Cargo.toml ]; then
+ echo "Must be run from root of project."
+ exit 1
+fi
+
+
+# Building openssl on Windows is a pain.
+if [[ $(rustc -Vv | grep host:) != *windows* ]]; then
+ FEATURES='vendored-openssl,curl-sys/static-curl,curl-sys/force-system-lib-on-osx'
+ export LIBZ_SYS_STATIC=1
+fi
+
+cargo build --features "$FEATURES"
+export CARGO_HOME=$RUNNER_TEMP/chome
+target/debug/cargo fetch
+rm -rf $CARGO_HOME