summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/crates/rustfix/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/crates/rustfix/Cargo.toml')
-rw-r--r--src/tools/cargo/crates/rustfix/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/tools/cargo/crates/rustfix/Cargo.toml b/src/tools/cargo/crates/rustfix/Cargo.toml
new file mode 100644
index 000000000..7947f0268
--- /dev/null
+++ b/src/tools/cargo/crates/rustfix/Cargo.toml
@@ -0,0 +1,34 @@
+[package]
+name = "rustfix"
+version = "0.7.0"
+authors = [
+ "Pascal Hertleif <killercup@gmail.com>",
+ "Oliver Schneider <oli-obk@users.noreply.github.com>",
+]
+rust-version = "1.70.0" # MSRV:3
+edition.workspace = true
+license.workspace = true
+homepage = "https://github.com/rust-lang/cargo"
+repository = "https://github.com/rust-lang/cargo"
+description = "Automatically apply the suggestions made by rustc"
+documentation = "https://docs.rs/rustfix"
+exclude = [
+ "examples/*",
+ "tests/*",
+]
+
+[dependencies]
+serde = { workspace = true, features = ["derive"] }
+serde_json.workspace = true
+thiserror.workspace = true
+tracing.workspace = true
+
+[dev-dependencies]
+anyhow.workspace = true
+proptest.workspace = true
+similar = "2.3.0"
+tempfile.workspace = true
+tracing-subscriber.workspace = true
+
+[lints]
+workspace = true