summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/src/doc/man/cargo-search.md
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/src/doc/man/cargo-search.md')
-rw-r--r--src/tools/cargo/src/doc/man/cargo-search.md52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/tools/cargo/src/doc/man/cargo-search.md b/src/tools/cargo/src/doc/man/cargo-search.md
new file mode 100644
index 000000000..f3d87cb12
--- /dev/null
+++ b/src/tools/cargo/src/doc/man/cargo-search.md
@@ -0,0 +1,52 @@
+# cargo-search(1)
+
+## NAME
+
+cargo-search --- Search packages in crates.io
+
+## SYNOPSIS
+
+`cargo search` [_options_] [_query_...]
+
+## DESCRIPTION
+
+This performs a textual search for crates on <https://crates.io>. The matching
+crates will be displayed along with their description in TOML format suitable
+for copying into a `Cargo.toml` manifest.
+
+## OPTIONS
+
+### Search Options
+
+{{#options}}
+
+{{#option "`--limit` _limit_" }}
+Limit the number of results (default: 10, max: 100).
+{{/option}}
+
+{{> options-index }}
+
+{{> options-registry }}
+
+{{/options}}
+
+### Display Options
+
+{{#options}}
+{{> options-display }}
+{{/options}}
+
+{{> section-options-common }}
+
+{{> section-environment }}
+
+{{> section-exit-status }}
+
+## EXAMPLES
+
+1. Search for a package from crates.io:
+
+ cargo search serde
+
+## SEE ALSO
+{{man "cargo" 1}}, {{man "cargo-install" 1}}, {{man "cargo-publish" 1}}