summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile')
-rw-r--r--src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/Cargo.toml13
-rw-r--r--src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/src/lib.rs1
-rw-r--r--src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/mod.rs25
-rw-r--r--src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/out/Cargo.toml10
-rw-r--r--src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stderr.log1
-rw-r--r--src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stdout.log0
6 files changed, 50 insertions, 0 deletions
diff --git a/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/Cargo.toml b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/Cargo.toml
new file mode 100644
index 000000000..a25e33ae0
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "cargo-remove-test-fixture"
+version = "0.1.0"
+
+[[bin]]
+name = "main"
+path = "src/main.rs"
+
+[dependencies]
+toml = "0.1"
+
+[profile.dev.package."*"]
+opt-level = 3 \ No newline at end of file
diff --git a/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/src/lib.rs b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/src/lib.rs
new file mode 100644
index 000000000..8b1378917
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/in/src/lib.rs
@@ -0,0 +1 @@
+
diff --git a/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/mod.rs b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/mod.rs
new file mode 100644
index 000000000..2d587455c
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/mod.rs
@@ -0,0 +1,25 @@
+use cargo_test_support::compare::assert_ui;
+use cargo_test_support::curr_dir;
+use cargo_test_support::CargoCommand;
+use cargo_test_support::Project;
+
+#[cargo_test]
+fn case() {
+ cargo_test_support::registry::init();
+ cargo_test_support::registry::Package::new("toml", "0.1.1+my-package").publish();
+
+ let project = Project::from_template(curr_dir!().join("in"));
+ let project_root = project.root();
+ let cwd = &project_root;
+
+ snapbox::cmd::Command::cargo_ui()
+ .arg("remove")
+ .args(["toml"])
+ .current_dir(cwd)
+ .assert()
+ .success()
+ .stdout_matches_path(curr_dir!().join("stdout.log"))
+ .stderr_matches_path(curr_dir!().join("stderr.log"));
+
+ assert_ui().subset_matches(curr_dir!().join("out"), &project_root);
+}
diff --git a/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/out/Cargo.toml b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/out/Cargo.toml
new file mode 100644
index 000000000..76e3bcf77
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/out/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "cargo-remove-test-fixture"
+version = "0.1.0"
+
+[[bin]]
+name = "main"
+path = "src/main.rs"
+
+[profile.dev.package."*"]
+opt-level = 3
diff --git a/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stderr.log b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stderr.log
new file mode 100644
index 000000000..9dee9e2b7
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stderr.log
@@ -0,0 +1 @@
+ Removing toml from dependencies
diff --git a/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stdout.log b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stdout.log
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/cargo_remove/skip_gc_glob_profile/stdout.log