summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/mock-std/library/core
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/tests/testsuite/mock-std/library/core')
-rw-r--r--src/tools/cargo/tests/testsuite/mock-std/library/core/Cargo.toml5
-rw-r--r--src/tools/cargo/tests/testsuite/mock-std/library/core/src/lib.rs9
2 files changed, 14 insertions, 0 deletions
diff --git a/src/tools/cargo/tests/testsuite/mock-std/library/core/Cargo.toml b/src/tools/cargo/tests/testsuite/mock-std/library/core/Cargo.toml
new file mode 100644
index 000000000..3f7de53db
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/mock-std/library/core/Cargo.toml
@@ -0,0 +1,5 @@
+[package]
+name = "core"
+version = "0.1.0"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+edition = "2018"
diff --git a/src/tools/cargo/tests/testsuite/mock-std/library/core/src/lib.rs b/src/tools/cargo/tests/testsuite/mock-std/library/core/src/lib.rs
new file mode 100644
index 000000000..b90ed0914
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/mock-std/library/core/src/lib.rs
@@ -0,0 +1,9 @@
+#![feature(staged_api)]
+#![stable(since = "1.0.0", feature = "dummy")]
+
+#[stable(since = "1.0.0", feature = "dummy")]
+pub use core::*;
+
+#[stable(since = "1.0.0", feature = "dummy")]
+pub fn custom_api() {
+}