summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/mock-std/library/std
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/tests/testsuite/mock-std/library/std')
-rw-r--r--src/tools/cargo/tests/testsuite/mock-std/library/std/Cargo.toml11
-rw-r--r--src/tools/cargo/tests/testsuite/mock-std/library/std/src/lib.rs12
2 files changed, 23 insertions, 0 deletions
diff --git a/src/tools/cargo/tests/testsuite/mock-std/library/std/Cargo.toml b/src/tools/cargo/tests/testsuite/mock-std/library/std/Cargo.toml
new file mode 100644
index 000000000..d2cfdea39
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/mock-std/library/std/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "std"
+version = "0.1.0"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+edition = "2018"
+
+[dependencies]
+registry-dep-using-alloc = { version = "*", features = ['mockbuild'] }
+
+[features]
+feature1 = []
diff --git a/src/tools/cargo/tests/testsuite/mock-std/library/std/src/lib.rs b/src/tools/cargo/tests/testsuite/mock-std/library/std/src/lib.rs
new file mode 100644
index 000000000..146d4c42c
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/mock-std/library/std/src/lib.rs
@@ -0,0 +1,12 @@
+#![feature(staged_api)]
+#![stable(since = "1.0.0", feature = "dummy")]
+
+#[stable(since = "1.0.0", feature = "dummy")]
+pub use std::*;
+
+#[stable(since = "1.0.0", feature = "dummy")]
+pub fn custom_api() {}
+
+#[cfg(feature = "feature1")]
+#[stable(since = "1.0.0", feature = "dummy")]
+pub fn conditional_function() {}