summaryrefslogtreecommitdiffstats
path: root/src/tools/clippy/lintcheck/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/clippy/lintcheck/Cargo.toml')
-rw-r--r--src/tools/clippy/lintcheck/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/tools/clippy/lintcheck/Cargo.toml b/src/tools/clippy/lintcheck/Cargo.toml
new file mode 100644
index 000000000..737c845c0
--- /dev/null
+++ b/src/tools/clippy/lintcheck/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "lintcheck"
+version = "0.0.1"
+description = "tool to monitor impact of changes in Clippy's lints on a part of the ecosystem"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/rust-clippy"
+categories = ["development-tools"]
+edition = "2021"
+publish = false
+
+[dependencies]
+cargo_metadata = "0.14"
+clap = "3.2"
+flate2 = "1.0"
+rayon = "1.5.1"
+serde = { version = "1.0", features = ["derive"] }
+tar = "0.4"
+toml = "0.5"
+ureq = "2.2"
+walkdir = "2.3"
+
+[features]
+deny-warnings = []