summaryrefslogtreecommitdiffstats
path: root/src/tools/clippy/src/docs/wildcard_dependencies.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/clippy/src/docs/wildcard_dependencies.txt')
-rw-r--r--src/tools/clippy/src/docs/wildcard_dependencies.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/tools/clippy/src/docs/wildcard_dependencies.txt b/src/tools/clippy/src/docs/wildcard_dependencies.txt
new file mode 100644
index 000000000..2affaf974
--- /dev/null
+++ b/src/tools/clippy/src/docs/wildcard_dependencies.txt
@@ -0,0 +1,13 @@
+### What it does
+Checks for wildcard dependencies in the `Cargo.toml`.
+
+### Why is this bad?
+[As the edition guide says](https://rust-lang-nursery.github.io/edition-guide/rust-2018/cargo-and-crates-io/crates-io-disallows-wildcard-dependencies.html),
+it is highly unlikely that you work with any possible version of your dependency,
+and wildcard dependencies would cause unnecessary breakage in the ecosystem.
+
+### Example
+```
+[dependencies]
+regex = "*"
+``` \ No newline at end of file