summaryrefslogtreecommitdiffstats
path: root/src/tools/clippy/tests/workspace_test/path_dep
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/clippy/tests/workspace_test/path_dep')
-rw-r--r--src/tools/clippy/tests/workspace_test/path_dep/Cargo.toml3
-rw-r--r--src/tools/clippy/tests/workspace_test/path_dep/src/lib.rs6
2 files changed, 9 insertions, 0 deletions
diff --git a/src/tools/clippy/tests/workspace_test/path_dep/Cargo.toml b/src/tools/clippy/tests/workspace_test/path_dep/Cargo.toml
new file mode 100644
index 000000000..85a91cd2d
--- /dev/null
+++ b/src/tools/clippy/tests/workspace_test/path_dep/Cargo.toml
@@ -0,0 +1,3 @@
+[package]
+name = "path_dep"
+version = "0.1.0"
diff --git a/src/tools/clippy/tests/workspace_test/path_dep/src/lib.rs b/src/tools/clippy/tests/workspace_test/path_dep/src/lib.rs
new file mode 100644
index 000000000..35ce524f2
--- /dev/null
+++ b/src/tools/clippy/tests/workspace_test/path_dep/src/lib.rs
@@ -0,0 +1,6 @@
+#![deny(clippy::empty_loop)]
+
+#[cfg(feature = "primary_package_test")]
+pub fn lint_me() {
+ loop {}
+}