summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rust-analyzer/Cargo.toml')
-rw-r--r--src/tools/rust-analyzer/Cargo.toml47
1 files changed, 32 insertions, 15 deletions
diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
index cab88fc18..1213979c3 100644
--- a/src/tools/rust-analyzer/Cargo.toml
+++ b/src/tools/rust-analyzer/Cargo.toml
@@ -42,7 +42,7 @@ debug = 0
# ungrammar = { path = "../ungrammar" }
-# salsa = { path = "../salsa" }
+# rust-analyzer-salsa = { path = "../salsa" }
[workspace.dependencies]
# local crates
@@ -79,33 +79,50 @@ toolchain = { path = "./crates/toolchain", version = "0.0.0" }
tt = { path = "./crates/tt", version = "0.0.0" }
vfs-notify = { path = "./crates/vfs-notify", version = "0.0.0" }
vfs = { path = "./crates/vfs", version = "0.0.0" }
+rustc-dependencies = { path = "./crates/rustc-dependencies", version = "0.0.0" }
# local crates that aren't published to crates.io. These should not have versions.
proc-macro-test = { path = "./crates/proc-macro-test" }
# In-tree crates that are published separately and follow semver. See lib/README.md
-line-index = { version = "0.1.0-pre.1" }
+line-index = { version = "0.1.1" }
la-arena = { version = "0.3.1" }
lsp-server = { version = "0.7.4" }
# non-local crates
+anyhow = "1.0.75"
+bitflags = "2.4.1"
+cargo_metadata = "0.18.1"
+dissimilar = "1.0.7"
+either = "1.9.0"
+hashbrown = { version = "0.14", features = [
+ "inline-more",
+], default-features = false }
+indexmap = "2.1.0"
+itertools = "0.12.0"
+libc = "0.2.150"
+nohash-hasher = "0.2.0"
+rayon = "1.8.0"
+rust-analyzer-salsa = "0.17.0-pre.4"
+rustc-hash = "1.1.0"
+serde = { version = "1.0.192", features = ["derive"] }
+serde_json = "1.0.108"
smallvec = { version = "1.10.0", features = [
"const_new",
"union",
"const_generics",
] }
smol_str = "0.2.0"
-nohash-hasher = "0.2.0"
-text-size = "1.1.0"
-serde = { version = "1.0.156", features = ["derive"] }
-serde_json = "1.0.96"
-triomphe = { version = "0.1.8", default-features = false, features = ["std"] }
-# can't upgrade due to dashmap depending on 0.12.3 currently
-hashbrown = { version = "0.12.3", features = ["inline-more"], default-features = false }
-
-rustc_lexer = { version = "0.10.0", package = "ra-ap-rustc_lexer" }
-rustc_parse_format = { version = "0.10.0", package = "ra-ap-rustc_parse_format", default-features = false }
+text-size = "1.1.1"
+tracing = "0.1.40"
+tracing-tree = "0.3.0"
+tracing-subscriber = { version = "0.3.18", default-features = false, features = [
+ "registry",
+ "fmt",
+ "tracing-log",
+] }
+triomphe = { version = "0.1.10", default-features = false, features = ["std"] }
+xshell = "0.2.5"
-# Upstream broke this for us so we can't update it
-rustc_abi = { version = "0.0.20221221", package = "hkalbasi-rustc-ap-rustc_abi", default-features = false }
-rustc_index = { version = "0.0.20221221", package = "hkalbasi-rustc-ap-rustc_index", default-features = false }
+# We need to freeze the version of the crate, as the raw-api feature is considered unstable
+dashmap = { version = "=5.5.3", features = ["raw-api"] }