summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/crates/hir-ty/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rust-analyzer/crates/hir-ty/Cargo.toml')
-rw-r--r--src/tools/rust-analyzer/crates/hir-ty/Cargo.toml29
1 files changed, 15 insertions, 14 deletions
diff --git a/src/tools/rust-analyzer/crates/hir-ty/Cargo.toml b/src/tools/rust-analyzer/crates/hir-ty/Cargo.toml
index b95ae05cc..bbcb76a43 100644
--- a/src/tools/rust-analyzer/crates/hir-ty/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/hir-ty/Cargo.toml
@@ -13,27 +13,27 @@ doctest = false
[dependencies]
cov-mark = "2.0.0-pre.1"
-itertools = "0.10.5"
+itertools.workspace = true
arrayvec = "0.7.2"
-bitflags = "2.1.0"
+bitflags.workspace = true
smallvec.workspace = true
ena = "0.14.0"
-either = "1.7.0"
+either.workspace = true
oorandom = "11.1.3"
-tracing = "0.1.35"
+tracing.workspace = true
rustc-hash = "1.1.0"
scoped-tls = "1.0.0"
-chalk-solve = { version = "0.92.0", default-features = false }
-chalk-ir = "0.92.0"
-chalk-recursive = { version = "0.92.0", default-features = false }
-chalk-derive = "0.92.0"
+chalk-solve = { version = "0.95.0", default-features = false }
+chalk-ir = "0.95.0"
+chalk-recursive = { version = "0.95.0", default-features = false }
+chalk-derive = "0.95.0"
la-arena.workspace = true
once_cell = "1.17.0"
triomphe.workspace = true
nohash-hasher.workspace = true
typed-arena = "2.0.1"
-rustc_index.workspace = true
+rustc-dependencies.workspace = true
# local deps
stdx.workspace = true
@@ -47,12 +47,13 @@ limit.workspace = true
[dev-dependencies]
expect-test = "1.4.0"
-tracing = "0.1.35"
-tracing-subscriber = { version = "0.3.16", default-features = false, features = [
- "registry",
-] }
-tracing-tree = "0.2.1"
+tracing.workspace = true
+tracing-subscriber.workspace = true
+tracing-tree.workspace = true
project-model = { path = "../project-model" }
# local deps
test-utils.workspace = true
+
+[features]
+in-rust-tree = ["rustc-dependencies/in-rust-tree"]