summaryrefslogtreecommitdiffstats
path: root/src/tools/rustc-workspace-hack/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rustc-workspace-hack/Cargo.toml')
-rw-r--r--src/tools/rustc-workspace-hack/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/tools/rustc-workspace-hack/Cargo.toml b/src/tools/rustc-workspace-hack/Cargo.toml
index 80bb3b5d6..a5f0c0f32 100644
--- a/src/tools/rustc-workspace-hack/Cargo.toml
+++ b/src/tools/rustc-workspace-hack/Cargo.toml
@@ -75,6 +75,8 @@ features = [
bstr = { version = "0.2.17", features = ["default"] }
clap = { version = "3.1.1", features = ["derive", "clap_derive"]}
curl-sys = { version = "0.4.13", features = ["http2", "libnghttp2-sys"], optional = true }
+# Ensure `extra_traits` of libc, which is used transitively by Cargo.
+libc = { version = "0.2", features = ["extra_traits"] }
# Ensure default features of libz-sys, which are disabled in some scenarios.
libz-sys = { version = "1.1.2" }
# Ensure default features of regex, which are disabled in some scenarios.
@@ -82,6 +84,8 @@ regex = { version = "1.5.6" }
serde_json = { version = "1.0.31", features = ["raw_value", "unbounded_depth"] }
syn = { version = "1", features = ['full', 'visit'] }
url = { version = "2.0", features = ['serde'] }
+# Ensure default features of rand, which are disabled in some scenarios.
+rand = { version = "0.8.5" }
[target.'cfg(not(windows))'.dependencies]
openssl = { version = "0.10.35", optional = true }