summaryrefslogtreecommitdiffstats
path: root/src/tools/rustdoc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rustdoc/Cargo.toml')
-rw-r--r--src/tools/rustdoc/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/tools/rustdoc/Cargo.toml b/src/tools/rustdoc/Cargo.toml
new file mode 100644
index 000000000..c4101f72c
--- /dev/null
+++ b/src/tools/rustdoc/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "rustdoc-tool"
+version = "0.0.0"
+edition = "2021"
+
+# Cargo adds a number of paths to the dylib search path on windows, which results in
+# the wrong rustdoc being executed. To avoid the conflicting rustdocs, we name the "tool"
+# rustdoc a different name.
+[[bin]]
+name = "rustdoc_tool_binary"
+path = "main.rs"
+
+[dependencies]
+rustdoc = { path = "../../librustdoc" }
+
+[features]
+jemalloc = ['rustdoc/jemalloc']