summaryrefslogtreecommitdiffstats
path: root/src/tools/rustfmt/Contributing.md
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rustfmt/Contributing.md')
-rw-r--r--src/tools/rustfmt/Contributing.md10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/tools/rustfmt/Contributing.md b/src/tools/rustfmt/Contributing.md
index 307399601..b986a887c 100644
--- a/src/tools/rustfmt/Contributing.md
+++ b/src/tools/rustfmt/Contributing.md
@@ -91,6 +91,16 @@ Please try to avoid leaving `TODO`s in the code. There are a few around, but I
wish there weren't. You can leave `FIXME`s, preferably with an issue number.
+### Run Rustfmt from source code
+
+You may want to run a version of rustfmt from source code as part of a test or
+hacking on the rustfmt codebase. It's strongly discouraged to install a version
+of rustfmt from source. Instead, run it using `cargo run`, and `--manifest-path`.
+
+```
+cargo run --bin cargo-fmt -- --manifest-path path/to/project/you/want2test/Cargo.toml
+```
+
### Version-gate formatting changes
A change that introduces a different code-formatting should be gated on the