summaryrefslogtreecommitdiffstats
path: root/src/tools/rustfmt/config_proc_macro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rustfmt/config_proc_macro/Cargo.toml')
-rw-r--r--src/tools/rustfmt/config_proc_macro/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/tools/rustfmt/config_proc_macro/Cargo.toml b/src/tools/rustfmt/config_proc_macro/Cargo.toml
new file mode 100644
index 000000000..a41b3a5e6
--- /dev/null
+++ b/src/tools/rustfmt/config_proc_macro/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "rustfmt-config_proc_macro"
+version = "0.2.0"
+edition = "2018"
+description = "A collection of procedural macros for rustfmt"
+license = "Apache-2.0/MIT"
+categories = ["development-tools::procedural-macro-helpers"]
+repository = "https://github.com/rust-lang/rustfmt"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+proc-macro2 = "1.0"
+quote = "1.0"
+syn = { version = "1.0", features = ["full", "visit"] }
+
+[dev-dependencies]
+serde = { version = "1.0", features = ["derive"] }
+
+[features]
+default = []
+debug-with-rustfmt = []