summaryrefslogtreecommitdiffstats
path: root/src/tools/tidy/src/edition.rs
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/tidy/src/edition.rs')
-rw-r--r--src/tools/tidy/src/edition.rs37
1 files changed, 15 insertions, 22 deletions
diff --git a/src/tools/tidy/src/edition.rs b/src/tools/tidy/src/edition.rs
index 8172e3d29..f28f677e0 100644
--- a/src/tools/tidy/src/edition.rs
+++ b/src/tools/tidy/src/edition.rs
@@ -9,27 +9,20 @@ fn is_edition_2021(mut line: &str) -> bool {
}
pub fn check(path: &Path, bad: &mut bool) {
- walk(
- path,
- &mut |path| {
- filter_dirs(path)
- || (path.ends_with("tests") && path.join("COMPILER_TESTS.md").exists())
- },
- &mut |entry, contents| {
- let file = entry.path();
- let filename = file.file_name().unwrap();
- if filename != "Cargo.toml" {
- return;
- }
+ walk(path, |path, _is_dir| filter_dirs(path), &mut |entry, contents| {
+ let file = entry.path();
+ let filename = file.file_name().unwrap();
+ if filename != "Cargo.toml" {
+ return;
+ }
- let is_2021 = contents.lines().any(is_edition_2021);
- if !is_2021 {
- tidy_error!(
- bad,
- "{} doesn't have `edition = \"2021\"` on a separate line",
- file.display()
- );
- }
- },
- );
+ let is_2021 = contents.lines().any(is_edition_2021);
+ if !is_2021 {
+ tidy_error!(
+ bad,
+ "{} doesn't have `edition = \"2021\"` on a separate line",
+ file.display()
+ );
+ }
+ });
}