summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/extern-fn-with-packed-struct
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/extern-fn-with-packed-struct')
-rw-r--r--tests/run-make-fulldeps/extern-fn-with-packed-struct/Makefile5
-rw-r--r--tests/run-make-fulldeps/extern-fn-with-packed-struct/test.c26
-rw-r--r--tests/run-make-fulldeps/extern-fn-with-packed-struct/test.rs20
3 files changed, 51 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/extern-fn-with-packed-struct/Makefile b/tests/run-make-fulldeps/extern-fn-with-packed-struct/Makefile
new file mode 100644
index 000000000..4f5d026f2
--- /dev/null
+++ b/tests/run-make-fulldeps/extern-fn-with-packed-struct/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,test)
+ $(RUSTC) test.rs
+ $(call RUN,test) || exit 1
diff --git a/tests/run-make-fulldeps/extern-fn-with-packed-struct/test.c b/tests/run-make-fulldeps/extern-fn-with-packed-struct/test.c
new file mode 100644
index 000000000..c89f8272b
--- /dev/null
+++ b/tests/run-make-fulldeps/extern-fn-with-packed-struct/test.c
@@ -0,0 +1,26 @@
+// Pragma needed cause of gcc bug on windows: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=52991
+
+#include <assert.h>
+
+#ifdef _MSC_VER
+#pragma pack(push,1)
+struct Foo {
+ char a;
+ short b;
+ char c;
+};
+#else
+#pragma pack(1)
+struct __attribute__((packed)) Foo {
+ char a;
+ short b;
+ char c;
+};
+#endif
+
+struct Foo foo(struct Foo foo) {
+ assert(foo.a == 1);
+ assert(foo.b == 2);
+ assert(foo.c == 3);
+ return foo;
+}
diff --git a/tests/run-make-fulldeps/extern-fn-with-packed-struct/test.rs b/tests/run-make-fulldeps/extern-fn-with-packed-struct/test.rs
new file mode 100644
index 000000000..2f261efb5
--- /dev/null
+++ b/tests/run-make-fulldeps/extern-fn-with-packed-struct/test.rs
@@ -0,0 +1,20 @@
+#[repr(C, packed)]
+#[derive(Copy, Clone, Debug, PartialEq)]
+struct Foo {
+ a: i8,
+ b: i16,
+ c: i8,
+}
+
+#[link(name = "test", kind = "static")]
+extern "C" {
+ fn foo(f: Foo) -> Foo;
+}
+
+fn main() {
+ unsafe {
+ let a = Foo { a: 1, b: 2, c: 3 };
+ let b = foo(a);
+ assert_eq!(a, b);
+ }
+}