summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/foreign-exceptions/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/foreign-exceptions/Makefile')
-rw-r--r--tests/run-make-fulldeps/foreign-exceptions/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/foreign-exceptions/Makefile b/tests/run-make-fulldeps/foreign-exceptions/Makefile
new file mode 100644
index 000000000..38fe2773d
--- /dev/null
+++ b/tests/run-make-fulldeps/foreign-exceptions/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+all: foo
+ $(call RUN,foo)
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)