summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/obtain-borrowck/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/run-make-fulldeps/obtain-borrowck/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/obtain-borrowck/Makefile b/tests/run-make-fulldeps/obtain-borrowck/Makefile
new file mode 100644
index 000000000..212d0f67d
--- /dev/null
+++ b/tests/run-make-fulldeps/obtain-borrowck/Makefile
@@ -0,0 +1,26 @@
+include ../tools.mk
+
+# This example shows how to implement a rustc driver that retrieves MIR bodies
+# together with the borrow checker information.
+
+# How to run this
+# $ ./x.py test tests/run-make-fulldeps/obtain-borrowck
+
+DRIVER_BINARY := "$(TMPDIR)"/driver
+SYSROOT := $(shell $(RUSTC) --print sysroot)
+
+ifdef IS_WINDOWS
+LIBSTD := -L "$(SYSROOT)\\lib\\rustlib\\$(TARGET)\\lib"
+else
+LIBSTD :=
+endif
+
+all:
+ $(RUSTC) driver.rs -o "$(DRIVER_BINARY)"
+ $(TARGET_RPATH_ENV) "$(DRIVER_BINARY)" --sysroot $(SYSROOT) $(LIBSTD) test.rs -o "$(TMPDIR)/driver_test" > "$(TMPDIR)"/output.stdout
+
+ifdef RUSTC_BLESS_TEST
+ cp "$(TMPDIR)"/output.stdout output.stdout
+else
+ $(DIFF) output.stdout "$(TMPDIR)"/output.stdout
+endif