summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/output-filename-conflicts-with-directory
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/output-filename-conflicts-with-directory')
-rw-r--r--tests/run-make-fulldeps/output-filename-conflicts-with-directory/Makefile7
-rw-r--r--tests/run-make-fulldeps/output-filename-conflicts-with-directory/foo.rs1
2 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/output-filename-conflicts-with-directory/Makefile b/tests/run-make-fulldeps/output-filename-conflicts-with-directory/Makefile
new file mode 100644
index 000000000..45221356c
--- /dev/null
+++ b/tests/run-make-fulldeps/output-filename-conflicts-with-directory/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/foo.rs
+ mkdir $(TMPDIR)/foo
+ $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo 2>&1 \
+ | $(CGREP) -e "the generated executable for the input file \".*foo\.rs\" conflicts with the existing directory \".*foo\""
diff --git a/tests/run-make-fulldeps/output-filename-conflicts-with-directory/foo.rs b/tests/run-make-fulldeps/output-filename-conflicts-with-directory/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make-fulldeps/output-filename-conflicts-with-directory/foo.rs
@@ -0,0 +1 @@
+fn main() {}