summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/pgo-gen-lto
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/pgo-gen-lto')
-rw-r--r--tests/run-make-fulldeps/pgo-gen-lto/Makefile14
-rw-r--r--tests/run-make-fulldeps/pgo-gen-lto/test.rs1
2 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/pgo-gen-lto/Makefile b/tests/run-make-fulldeps/pgo-gen-lto/Makefile
new file mode 100644
index 000000000..3f2f6a838
--- /dev/null
+++ b/tests/run-make-fulldeps/pgo-gen-lto/Makefile
@@ -0,0 +1,14 @@
+# needs-profiler-support
+# ignore-windows-gnu
+
+# FIXME(mati865): MinGW GCC miscompiles compiler-rt profiling library but with Clang it works
+# properly. Since we only have GCC on the CI ignore the test for now.
+
+include ../tools.mk
+
+COMPILE_FLAGS=-Copt-level=3 -Clto=fat -Cprofile-generate="$(TMPDIR)"
+
+all:
+ $(RUSTC) $(COMPILE_FLAGS) test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)"/default_*.profraw ] || (echo "No .profraw file"; exit 1)
diff --git a/tests/run-make-fulldeps/pgo-gen-lto/test.rs b/tests/run-make-fulldeps/pgo-gen-lto/test.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make-fulldeps/pgo-gen-lto/test.rs
@@ -0,0 +1 @@
+fn main() {}