summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/remap-path-prefix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/remap-path-prefix')
-rw-r--r--tests/run-make-fulldeps/remap-path-prefix/Makefile9
-rw-r--r--tests/run-make-fulldeps/remap-path-prefix/auxiliary/lib.rs3
2 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/remap-path-prefix/Makefile b/tests/run-make-fulldeps/remap-path-prefix/Makefile
new file mode 100644
index 000000000..2a7378fdf
--- /dev/null
+++ b/tests/run-make-fulldeps/remap-path-prefix/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# ignore-windows
+
+# Checks if remapping works if the remap-from string contains path to the working directory plus more
+all:
+ $(RUSTC) --remap-path-prefix $$PWD/auxiliary=/the/aux --crate-type=lib --emit=metadata auxiliary/lib.rs
+ grep "/the/aux/lib.rs" $(TMPDIR)/liblib.rmeta || exit 1
+ ! grep "$$PWD/auxiliary" $(TMPDIR)/liblib.rmeta || exit 1
diff --git a/tests/run-make-fulldeps/remap-path-prefix/auxiliary/lib.rs b/tests/run-make-fulldeps/remap-path-prefix/auxiliary/lib.rs
new file mode 100644
index 000000000..019c786a9
--- /dev/null
+++ b/tests/run-make-fulldeps/remap-path-prefix/auxiliary/lib.rs
@@ -0,0 +1,3 @@
+pub fn lib() {
+ panic!("calm");
+}