summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/static-unwinding
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/static-unwinding')
-rw-r--r--tests/run-make-fulldeps/static-unwinding/Makefile6
-rw-r--r--tests/run-make-fulldeps/static-unwinding/lib.rs15
-rw-r--r--tests/run-make-fulldeps/static-unwinding/main.rs24
3 files changed, 45 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/static-unwinding/Makefile b/tests/run-make-fulldeps/static-unwinding/Makefile
new file mode 100644
index 000000000..9c755d4ab
--- /dev/null
+++ b/tests/run-make-fulldeps/static-unwinding/Makefile
@@ -0,0 +1,6 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs
+ $(call RUN,main)
diff --git a/tests/run-make-fulldeps/static-unwinding/lib.rs b/tests/run-make-fulldeps/static-unwinding/lib.rs
new file mode 100644
index 000000000..3fb1117a1
--- /dev/null
+++ b/tests/run-make-fulldeps/static-unwinding/lib.rs
@@ -0,0 +1,15 @@
+#![crate_type = "rlib"]
+
+pub static mut statik: isize = 0;
+
+struct A;
+impl Drop for A {
+ fn drop(&mut self) {
+ unsafe { statik = 1; }
+ }
+}
+
+pub fn callback<F>(f: F) where F: FnOnce() {
+ let _a = A;
+ f();
+}
diff --git a/tests/run-make-fulldeps/static-unwinding/main.rs b/tests/run-make-fulldeps/static-unwinding/main.rs
new file mode 100644
index 000000000..0c66ea1aa
--- /dev/null
+++ b/tests/run-make-fulldeps/static-unwinding/main.rs
@@ -0,0 +1,24 @@
+extern crate lib;
+
+use std::thread;
+
+static mut statik: isize = 0;
+
+struct A;
+impl Drop for A {
+ fn drop(&mut self) {
+ unsafe { statik = 1; }
+ }
+}
+
+fn main() {
+ thread::spawn(move|| {
+ let _a = A;
+ lib::callback(|| panic!());
+ }).join().unwrap_err();
+
+ unsafe {
+ assert_eq!(lib::statik, 1);
+ assert_eq!(statik, 1);
+ }
+}