summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-dynamic-rlib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-dynamic-rlib')
-rw-r--r--tests/run-make/c-dynamic-rlib/Makefile16
-rw-r--r--tests/run-make/c-dynamic-rlib/bar.rs5
-rw-r--r--tests/run-make/c-dynamic-rlib/cfoo.c4
-rw-r--r--tests/run-make/c-dynamic-rlib/foo.rs10
4 files changed, 35 insertions, 0 deletions
diff --git a/tests/run-make/c-dynamic-rlib/Makefile b/tests/run-make/c-dynamic-rlib/Makefile
new file mode 100644
index 000000000..0475bd8ac
--- /dev/null
+++ b/tests/run-make/c-dynamic-rlib/Makefile
@@ -0,0 +1,16 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-macos
+#
+# This hits an assertion in the linker on older versions of osx apparently
+
+# This overrides the LD_LIBRARY_PATH for RUN
+TARGET_RPATH_DIR:=$(TARGET_RPATH_DIR):$(TMPDIR)
+
+all: $(call DYLIB,cfoo)
+ $(RUSTC) foo.rs
+ $(RUSTC) bar.rs
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,cfoo)
+ $(call FAIL,bar)
diff --git a/tests/run-make/c-dynamic-rlib/bar.rs b/tests/run-make/c-dynamic-rlib/bar.rs
new file mode 100644
index 000000000..b8c798ffd
--- /dev/null
+++ b/tests/run-make/c-dynamic-rlib/bar.rs
@@ -0,0 +1,5 @@
+extern crate foo;
+
+fn main() {
+ foo::rsfoo();
+}
diff --git a/tests/run-make/c-dynamic-rlib/cfoo.c b/tests/run-make/c-dynamic-rlib/cfoo.c
new file mode 100644
index 000000000..fea490cf9
--- /dev/null
+++ b/tests/run-make/c-dynamic-rlib/cfoo.c
@@ -0,0 +1,4 @@
+#ifdef _WIN32
+__declspec(dllexport)
+#endif
+int foo() { return 0; }
diff --git a/tests/run-make/c-dynamic-rlib/foo.rs b/tests/run-make/c-dynamic-rlib/foo.rs
new file mode 100644
index 000000000..3dd376f1f
--- /dev/null
+++ b/tests/run-make/c-dynamic-rlib/foo.rs
@@ -0,0 +1,10 @@
+#![crate_type = "rlib"]
+
+#[link(name = "cfoo")]
+extern "C" {
+ fn foo();
+}
+
+pub fn rsfoo() {
+ unsafe { foo() }
+}