summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-link-to-rust-dylib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-link-to-rust-dylib')
-rw-r--r--tests/run-make/c-link-to-rust-dylib/Makefile18
-rw-r--r--tests/run-make/c-link-to-rust-dylib/bar.c6
-rw-r--r--tests/run-make/c-link-to-rust-dylib/foo.rs4
3 files changed, 28 insertions, 0 deletions
diff --git a/tests/run-make/c-link-to-rust-dylib/Makefile b/tests/run-make/c-link-to-rust-dylib/Makefile
new file mode 100644
index 000000000..2763cb6ed
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-dylib/Makefile
@@ -0,0 +1,18 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(TMPDIR)/$(call BIN,bar)
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,foo)
+ $(call FAIL,bar)
+
+ifdef IS_MSVC
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,bar)
+else
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c -lfoo -o $(call RUN_BINFILE,bar) -L $(TMPDIR)
+endif
+
+$(call DYLIB,foo): foo.rs
+ $(RUSTC) foo.rs
diff --git a/tests/run-make/c-link-to-rust-dylib/bar.c b/tests/run-make/c-link-to-rust-dylib/bar.c
new file mode 100644
index 000000000..bb4036b06
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-dylib/bar.c
@@ -0,0 +1,6 @@
+void foo();
+
+int main() {
+ foo();
+ return 0;
+}
diff --git a/tests/run-make/c-link-to-rust-dylib/foo.rs b/tests/run-make/c-link-to-rust-dylib/foo.rs
new file mode 100644
index 000000000..f197fa513
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-dylib/foo.rs
@@ -0,0 +1,4 @@
+#![crate_type = "dylib"]
+
+#[no_mangle]
+pub extern "C" fn foo() {}