summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-static-rlib
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-static-rlib')
-rw-r--r--tests/run-make/c-static-rlib/Makefile9
-rw-r--r--tests/run-make/c-static-rlib/bar.rs5
-rw-r--r--tests/run-make/c-static-rlib/cfoo.c1
-rw-r--r--tests/run-make/c-static-rlib/foo.rs10
4 files changed, 25 insertions, 0 deletions
diff --git a/tests/run-make/c-static-rlib/Makefile b/tests/run-make/c-static-rlib/Makefile
new file mode 100644
index 000000000..4e351127c
--- /dev/null
+++ b/tests/run-make/c-static-rlib/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,cfoo)
+ $(RUSTC) foo.rs
+ $(RUSTC) bar.rs
+ $(call REMOVE_RLIBS,foo)
+ rm $(call NATIVE_STATICLIB,cfoo)
+ $(call RUN,bar)
diff --git a/tests/run-make/c-static-rlib/bar.rs b/tests/run-make/c-static-rlib/bar.rs
new file mode 100644
index 000000000..b8c798ffd
--- /dev/null
+++ b/tests/run-make/c-static-rlib/bar.rs
@@ -0,0 +1,5 @@
+extern crate foo;
+
+fn main() {
+ foo::rsfoo();
+}
diff --git a/tests/run-make/c-static-rlib/cfoo.c b/tests/run-make/c-static-rlib/cfoo.c
new file mode 100644
index 000000000..9fe07f82f
--- /dev/null
+++ b/tests/run-make/c-static-rlib/cfoo.c
@@ -0,0 +1 @@
+int foo() { return 0; }
diff --git a/tests/run-make/c-static-rlib/foo.rs b/tests/run-make/c-static-rlib/foo.rs
new file mode 100644
index 000000000..9c6d2080e
--- /dev/null
+++ b/tests/run-make/c-static-rlib/foo.rs
@@ -0,0 +1,10 @@
+#![crate_type = "rlib"]
+
+#[link(name = "cfoo", kind = "static")]
+extern "C" {
+ fn foo();
+}
+
+pub fn rsfoo() {
+ unsafe { foo() }
+}