summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-unwind-abi-catch-panic
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-unwind-abi-catch-panic')
-rw-r--r--tests/run-make/c-unwind-abi-catch-panic/Makefile1
-rw-r--r--tests/run-make/c-unwind-abi-catch-panic/main.rs1
2 files changed, 1 insertions, 1 deletions
diff --git a/tests/run-make/c-unwind-abi-catch-panic/Makefile b/tests/run-make/c-unwind-abi-catch-panic/Makefile
index 4398ac2ee..1760ddb30 100644
--- a/tests/run-make/c-unwind-abi-catch-panic/Makefile
+++ b/tests/run-make/c-unwind-abi-catch-panic/Makefile
@@ -1,4 +1,5 @@
# ignore-cross-compile
+# needs-unwind
include ../tools.mk
all: $(call NATIVE_STATICLIB,add)
diff --git a/tests/run-make/c-unwind-abi-catch-panic/main.rs b/tests/run-make/c-unwind-abi-catch-panic/main.rs
index 15d38d721..1903be956 100644
--- a/tests/run-make/c-unwind-abi-catch-panic/main.rs
+++ b/tests/run-make/c-unwind-abi-catch-panic/main.rs
@@ -1,7 +1,6 @@
//! A test for calling `C-unwind` functions across foreign function boundaries.
//!
//! This test triggers a panic when calling a foreign function that calls *back* into Rust.
-#![feature(c_unwind)]
use std::panic::{catch_unwind, AssertUnwindSafe};