summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info-doesnt-run-much
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/dep-info-doesnt-run-much')
-rw-r--r--tests/run-make/dep-info-doesnt-run-much/Makefile4
-rw-r--r--tests/run-make/dep-info-doesnt-run-much/foo.rs5
2 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/dep-info-doesnt-run-much/Makefile b/tests/run-make/dep-info-doesnt-run-much/Makefile
new file mode 100644
index 000000000..b4dc44ad2
--- /dev/null
+++ b/tests/run-make/dep-info-doesnt-run-much/Makefile
@@ -0,0 +1,4 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs --emit dep-info
diff --git a/tests/run-make/dep-info-doesnt-run-much/foo.rs b/tests/run-make/dep-info-doesnt-run-much/foo.rs
new file mode 100644
index 000000000..316e68129
--- /dev/null
+++ b/tests/run-make/dep-info-doesnt-run-much/foo.rs
@@ -0,0 +1,5 @@
+// We're only emitting dep info, so we shouldn't be running static analysis to
+// figure out that this program is erroneous.
+fn main() {
+ let a: u8 = "a";
+}