summaryrefslogtreecommitdiffstats
path: root/tests/run-make/doctests-runtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/doctests-runtool/Makefile')
-rw-r--r--tests/run-make/doctests-runtool/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/doctests-runtool/Makefile b/tests/run-make/doctests-runtool/Makefile
new file mode 100644
index 000000000..7d5df1e30
--- /dev/null
+++ b/tests/run-make/doctests-runtool/Makefile
@@ -0,0 +1,20 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Tests behavior of rustdoc --runtool
+
+MY_SRC_DIR := ${CURDIR}
+
+all: with_test_run_directory
+
+# Behavior with --runtool with relative paths and --test-run-directory.
+with_test_run_directory:
+ mkdir -p $(TMPDIR)/rundir
+ mkdir -p $(TMPDIR)/runtool
+ $(RUSTC) --crate-type rlib t.rs
+ $(RUSTC) runtool.rs -o $(TMPDIR)/runtool/runtool
+ ( cd $(TMPDIR); \
+ $(RUSTDOC) -Zunstable-options --test --test-run-directory rundir \
+ --runtool runtool/runtool --extern t=libt.rlib $(MY_SRC_DIR)/t.rs \
+ )
+ rm -rf $(TMPDIR)/rundir $(TMPDIR)/runtool