summaryrefslogtreecommitdiffstats
path: root/tests/run-make/export-executable-symbols/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/export-executable-symbols/Makefile')
-rw-r--r--tests/run-make/export-executable-symbols/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/export-executable-symbols/Makefile b/tests/run-make/export-executable-symbols/Makefile
new file mode 100644
index 000000000..daa77c99d
--- /dev/null
+++ b/tests/run-make/export-executable-symbols/Makefile
@@ -0,0 +1,11 @@
+include ../../run-make-fulldeps/tools.mk
+
+# ignore-wasm32
+# ignore-wasm64
+# ignore-none no-std is not supported
+# only-linux
+
+all:
+ $(RUSTC) -Zexport-executable-symbols main.rs --target $(TARGET) --crate-type=bin
+ nm $(TMPDIR)/main | $(CGREP) exported_symbol
+