summaryrefslogtreecommitdiffstats
path: root/tests/run-make/extern-fn-generic
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/extern-fn-generic')
-rw-r--r--tests/run-make/extern-fn-generic/Makefile7
-rw-r--r--tests/run-make/extern-fn-generic/test.c16
-rw-r--r--tests/run-make/extern-fn-generic/test.rs20
-rw-r--r--tests/run-make/extern-fn-generic/testcrate.rs16
4 files changed, 59 insertions, 0 deletions
diff --git a/tests/run-make/extern-fn-generic/Makefile b/tests/run-make/extern-fn-generic/Makefile
new file mode 100644
index 000000000..7dceea6cb
--- /dev/null
+++ b/tests/run-make/extern-fn-generic/Makefile
@@ -0,0 +1,7 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,test)
+ $(RUSTC) testcrate.rs
+ $(RUSTC) test.rs
+ $(call RUN,test) || exit 1
diff --git a/tests/run-make/extern-fn-generic/test.c b/tests/run-make/extern-fn-generic/test.c
new file mode 100644
index 000000000..a8504ff2a
--- /dev/null
+++ b/tests/run-make/extern-fn-generic/test.c
@@ -0,0 +1,16 @@
+#include <stdint.h>
+
+typedef struct TestStruct {
+ uint8_t x;
+ int32_t y;
+} TestStruct;
+
+typedef int callback(TestStruct s);
+
+uint32_t call(callback *c) {
+ TestStruct s;
+ s.x = 'a';
+ s.y = 3;
+
+ return c(s);
+}
diff --git a/tests/run-make/extern-fn-generic/test.rs b/tests/run-make/extern-fn-generic/test.rs
new file mode 100644
index 000000000..c9baa4898
--- /dev/null
+++ b/tests/run-make/extern-fn-generic/test.rs
@@ -0,0 +1,20 @@
+extern crate testcrate;
+
+extern "C" fn bar<T>(ts: testcrate::TestStruct<T>) -> T {
+ ts.y
+}
+
+#[link(name = "test", kind = "static")]
+extern "C" {
+ fn call(c: extern "C" fn(testcrate::TestStruct<i32>) -> i32) -> i32;
+}
+
+fn main() {
+ // Let's test calling it cross crate
+ let back = unsafe { testcrate::call(testcrate::foo::<i32>) };
+ assert_eq!(3, back);
+
+ // And just within this crate
+ let back = unsafe { call(bar::<i32>) };
+ assert_eq!(3, back);
+}
diff --git a/tests/run-make/extern-fn-generic/testcrate.rs b/tests/run-make/extern-fn-generic/testcrate.rs
new file mode 100644
index 000000000..39f76e59c
--- /dev/null
+++ b/tests/run-make/extern-fn-generic/testcrate.rs
@@ -0,0 +1,16 @@
+#![crate_type = "lib"]
+
+#[repr(C)]
+pub struct TestStruct<T> {
+ pub x: u8,
+ pub y: T,
+}
+
+pub extern "C" fn foo<T>(ts: TestStruct<T>) -> T {
+ ts.y
+}
+
+#[link(name = "test", kind = "static")]
+extern "C" {
+ pub fn call(c: extern "C" fn(TestStruct<i32>) -> i32) -> i32;
+}