summaryrefslogtreecommitdiffstats
path: root/tests/run-make/extern-multiple-copies2
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/extern-multiple-copies2')
-rw-r--r--tests/run-make/extern-multiple-copies2/Makefile11
-rw-r--r--tests/run-make/extern-multiple-copies2/bar.rs8
-rw-r--r--tests/run-make/extern-multiple-copies2/foo1.rs7
-rw-r--r--tests/run-make/extern-multiple-copies2/foo2.rs8
4 files changed, 34 insertions, 0 deletions
diff --git a/tests/run-make/extern-multiple-copies2/Makefile b/tests/run-make/extern-multiple-copies2/Makefile
new file mode 100644
index 000000000..708b1c1b5
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies2/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo1.rs
+ $(RUSTC) foo2.rs
+ mkdir $(TMPDIR)/foo
+ cp $(TMPDIR)/libfoo1.rlib $(TMPDIR)/foo/libfoo1.rlib
+ $(RUSTC) bar.rs \
+ --extern foo1=$(TMPDIR)/foo/libfoo1.rlib \
+ --extern foo2=$(TMPDIR)/libfoo2.rlib
diff --git a/tests/run-make/extern-multiple-copies2/bar.rs b/tests/run-make/extern-multiple-copies2/bar.rs
new file mode 100644
index 000000000..b3088152d
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies2/bar.rs
@@ -0,0 +1,8 @@
+#[macro_use]
+extern crate foo2; // foo2 first to exhibit the bug
+#[macro_use]
+extern crate foo1;
+
+fn main() {
+ foo2::foo2(foo1::A);
+}
diff --git a/tests/run-make/extern-multiple-copies2/foo1.rs b/tests/run-make/extern-multiple-copies2/foo1.rs
new file mode 100644
index 000000000..4c778e52f
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies2/foo1.rs
@@ -0,0 +1,7 @@
+#![crate_type = "rlib"]
+
+pub struct A;
+
+pub fn foo1(a: A) {
+ drop(a);
+}
diff --git a/tests/run-make/extern-multiple-copies2/foo2.rs b/tests/run-make/extern-multiple-copies2/foo2.rs
new file mode 100644
index 000000000..2be103507
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies2/foo2.rs
@@ -0,0 +1,8 @@
+#![crate_type = "rlib"]
+
+#[macro_use]
+extern crate foo1;
+
+pub fn foo2(a: foo1::A) {
+ foo1::foo1(a);
+}