summaryrefslogtreecommitdiffstats
path: root/tests/run-make/fmt-write-bloat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/fmt-write-bloat/Makefile')
-rw-r--r--tests/run-make/fmt-write-bloat/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/run-make/fmt-write-bloat/Makefile b/tests/run-make/fmt-write-bloat/Makefile
new file mode 100644
index 000000000..07e6e025e
--- /dev/null
+++ b/tests/run-make/fmt-write-bloat/Makefile
@@ -0,0 +1,25 @@
+include ../../run-make-fulldeps/tools.mk
+
+# ignore-windows
+
+ifeq ($(shell $(RUSTC) -vV | grep 'host: $(TARGET)'),)
+
+# Don't run this test when cross compiling.
+all:
+
+else
+
+NM = nm
+
+PANIC_SYMS = panic_bounds_check pad_integral Display Debug
+
+# Allow for debug_assert!() in debug builds of std.
+ifdef NO_DEBUG_ASSERTIONS
+PANIC_SYMS += panicking panic_fmt
+endif
+
+all: main.rs
+ $(RUSTC) $< -O
+ $(NM) $(call RUN_BINFILE,main) | $(CGREP) -v $(PANIC_SYMS)
+
+endif