summaryrefslogtreecommitdiffstats
path: root/tests/run-make/foreign-double-unwind
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/foreign-double-unwind')
-rw-r--r--tests/run-make/foreign-double-unwind/Makefile11
-rw-r--r--tests/run-make/foreign-double-unwind/foo.cpp33
-rw-r--r--tests/run-make/foreign-double-unwind/foo.rs26
3 files changed, 70 insertions, 0 deletions
diff --git a/tests/run-make/foreign-double-unwind/Makefile b/tests/run-make/foreign-double-unwind/Makefile
new file mode 100644
index 000000000..f20fe3ce6
--- /dev/null
+++ b/tests/run-make/foreign-double-unwind/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: foo
+ $(call RUN,foo) | $(CGREP) -v unreachable
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)
diff --git a/tests/run-make/foreign-double-unwind/foo.cpp b/tests/run-make/foreign-double-unwind/foo.cpp
new file mode 100644
index 000000000..69a8f11c2
--- /dev/null
+++ b/tests/run-make/foreign-double-unwind/foo.cpp
@@ -0,0 +1,33 @@
+#include <cstdio>
+#include <exception>
+
+void println(const char* s) {
+ puts(s);
+ fflush(stdout);
+}
+
+struct outer_exception {};
+struct inner_exception {};
+
+extern "C" {
+ void throw_cxx_exception() {
+ if (std::uncaught_exception()) {
+ println("throwing inner C++ exception");
+ throw inner_exception();
+ } else {
+ println("throwing outer C++ exception");
+ throw outer_exception();
+ }
+ }
+
+ void cxx_catch_callback(void (*cb)()) {
+ try {
+ cb();
+ println("unreachable: callback returns");
+ } catch (outer_exception) {
+ println("unreachable: caught outer exception in catch (...)");
+ } catch (inner_exception) {
+ println("unreachable: caught inner exception in catch (...)");
+ }
+ }
+}
diff --git a/tests/run-make/foreign-double-unwind/foo.rs b/tests/run-make/foreign-double-unwind/foo.rs
new file mode 100644
index 000000000..cae8aa940
--- /dev/null
+++ b/tests/run-make/foreign-double-unwind/foo.rs
@@ -0,0 +1,26 @@
+// Tests that C++ double unwinding through Rust code will be properly guarded
+// against instead of exhibiting undefined behaviour.
+
+#![feature(c_unwind)]
+
+extern "C-unwind" {
+ fn throw_cxx_exception();
+ fn cxx_catch_callback(cb: extern "C-unwind" fn());
+}
+
+struct ThrowOnDrop;
+
+impl Drop for ThrowOnDrop {
+ fn drop(&mut self) {
+ unsafe { throw_cxx_exception() };
+ }
+}
+
+extern "C-unwind" fn test_double_unwind() {
+ let _a = ThrowOnDrop;
+ let _b = ThrowOnDrop;
+}
+
+fn main() {
+ unsafe { cxx_catch_callback(test_double_unwind) };
+}