summaryrefslogtreecommitdiffstats
path: root/tests/run-make/glibc-staticlib-args
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/glibc-staticlib-args')
-rw-r--r--tests/run-make/glibc-staticlib-args/Makefile13
-rw-r--r--tests/run-make/glibc-staticlib-args/library.rs4
-rw-r--r--tests/run-make/glibc-staticlib-args/program.c6
3 files changed, 23 insertions, 0 deletions
diff --git a/tests/run-make/glibc-staticlib-args/Makefile b/tests/run-make/glibc-staticlib-args/Makefile
new file mode 100644
index 000000000..cad6c049e
--- /dev/null
+++ b/tests/run-make/glibc-staticlib-args/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+# only-gnu
+# only-linux
+
+include ../tools.mk
+
+# This ensures that std::env::args works in a library called from C on glibc Linux.
+
+all:
+ $(RUSTC) --crate-type=staticlib library.rs
+ $(CC) program.c $(call STATICLIB,library) $(call OUT_EXE,program) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,program)
diff --git a/tests/run-make/glibc-staticlib-args/library.rs b/tests/run-make/glibc-staticlib-args/library.rs
new file mode 100644
index 000000000..5ab627a2a
--- /dev/null
+++ b/tests/run-make/glibc-staticlib-args/library.rs
@@ -0,0 +1,4 @@
+#[no_mangle]
+pub extern "C" fn args_check() {
+ assert_ne!(std::env::args_os().count(), 0);
+}
diff --git a/tests/run-make/glibc-staticlib-args/program.c b/tests/run-make/glibc-staticlib-args/program.c
new file mode 100644
index 000000000..30f6974b7
--- /dev/null
+++ b/tests/run-make/glibc-staticlib-args/program.c
@@ -0,0 +1,6 @@
+void args_check();
+
+int main() {
+ args_check();
+ return 0;
+}