summaryrefslogtreecommitdiffstats
path: root/tests/run-make/hir-tree
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/hir-tree')
-rw-r--r--tests/run-make/hir-tree/Makefile8
-rw-r--r--tests/run-make/hir-tree/input.rs3
2 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/hir-tree/Makefile b/tests/run-make/hir-tree/Makefile
new file mode 100644
index 000000000..b0450ea4b
--- /dev/null
+++ b/tests/run-make/hir-tree/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+# Test that hir-tree output doesn't crash and includes
+# the string constant we would expect to see.
+
+all:
+ $(RUSTC) -o $(TMPDIR)/input.hir -Z unpretty=hir-tree input.rs
+ $(CGREP) '"Hello, Rustaceans!\n"' < $(TMPDIR)/input.hir
diff --git a/tests/run-make/hir-tree/input.rs b/tests/run-make/hir-tree/input.rs
new file mode 100644
index 000000000..9d1a4e9e4
--- /dev/null
+++ b/tests/run-make/hir-tree/input.rs
@@ -0,0 +1,3 @@
+fn main() {
+ println!("Hello, Rustaceans!");
+}