summaryrefslogtreecommitdiffstats
path: root/tests/run-make/include_bytes_deps
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/include_bytes_deps')
-rw-r--r--tests/run-make/include_bytes_deps/Makefile7
-rw-r--r--tests/run-make/include_bytes_deps/input.bin1
-rw-r--r--tests/run-make/include_bytes_deps/input.md1
-rw-r--r--tests/run-make/include_bytes_deps/input.txt1
-rw-r--r--tests/run-make/include_bytes_deps/main.rs10
5 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/include_bytes_deps/Makefile b/tests/run-make/include_bytes_deps/Makefile
new file mode 100644
index 000000000..696dfd207
--- /dev/null
+++ b/tests/run-make/include_bytes_deps/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+# ignore-freebsd
+
+all:
+ $(RUSTC) --emit dep-info main.rs
+ $(CGREP) "input.txt" "input.bin" "input.md" < $(TMPDIR)/main.d
diff --git a/tests/run-make/include_bytes_deps/input.bin b/tests/run-make/include_bytes_deps/input.bin
new file mode 100644
index 000000000..cd0875583
--- /dev/null
+++ b/tests/run-make/include_bytes_deps/input.bin
@@ -0,0 +1 @@
+Hello world!
diff --git a/tests/run-make/include_bytes_deps/input.md b/tests/run-make/include_bytes_deps/input.md
new file mode 100644
index 000000000..2a19b7405
--- /dev/null
+++ b/tests/run-make/include_bytes_deps/input.md
@@ -0,0 +1 @@
+# Hello, world!
diff --git a/tests/run-make/include_bytes_deps/input.txt b/tests/run-make/include_bytes_deps/input.txt
new file mode 100644
index 000000000..cd0875583
--- /dev/null
+++ b/tests/run-make/include_bytes_deps/input.txt
@@ -0,0 +1 @@
+Hello world!
diff --git a/tests/run-make/include_bytes_deps/main.rs b/tests/run-make/include_bytes_deps/main.rs
new file mode 100644
index 000000000..2fd55699d
--- /dev/null
+++ b/tests/run-make/include_bytes_deps/main.rs
@@ -0,0 +1,10 @@
+#[doc = include_str!("input.md")]
+pub struct SomeStruct;
+
+pub fn main() {
+ const INPUT_TXT: &'static str = include_str!("input.txt");
+ const INPUT_BIN: &'static [u8] = include_bytes!("input.bin");
+
+ println!("{}", INPUT_TXT);
+ println!("{:?}", INPUT_BIN);
+}