summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-14500
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-14500')
-rw-r--r--tests/run-make/issue-14500/Makefile15
-rw-r--r--tests/run-make/issue-14500/bar.rs1
-rw-r--r--tests/run-make/issue-14500/foo.c7
-rw-r--r--tests/run-make/issue-14500/foo.rs5
4 files changed, 28 insertions, 0 deletions
diff --git a/tests/run-make/issue-14500/Makefile b/tests/run-make/issue-14500/Makefile
new file mode 100644
index 000000000..eeab48de3
--- /dev/null
+++ b/tests/run-make/issue-14500/Makefile
@@ -0,0 +1,15 @@
+include ../tools.mk
+
+# ignore-cross-compile
+
+# Test to make sure that reachable extern fns are always available in final
+# productcs, including when LTO is used. In this test, the `foo` crate has a
+# reahable symbol, and is a dependency of the `bar` crate. When the `bar` crate
+# is compiled with LTO, it shouldn't strip the symbol from `foo`, and that's the
+# only way that `foo.c` will successfully compile.
+
+all:
+ $(RUSTC) foo.rs --crate-type=rlib
+ $(RUSTC) bar.rs --crate-type=staticlib -C lto -L. -o $(TMPDIR)/libbar.a
+ $(CC) foo.c $(TMPDIR)/libbar.a $(EXTRACFLAGS) $(call OUT_EXE,foo)
+ $(call RUN,foo)
diff --git a/tests/run-make/issue-14500/bar.rs b/tests/run-make/issue-14500/bar.rs
new file mode 100644
index 000000000..49af74e1b
--- /dev/null
+++ b/tests/run-make/issue-14500/bar.rs
@@ -0,0 +1 @@
+extern crate foo;
diff --git a/tests/run-make/issue-14500/foo.c b/tests/run-make/issue-14500/foo.c
new file mode 100644
index 000000000..2353d400d
--- /dev/null
+++ b/tests/run-make/issue-14500/foo.c
@@ -0,0 +1,7 @@
+extern void foo();
+extern char FOO_STATIC;
+
+int main() {
+ foo();
+ return (int)FOO_STATIC;
+}
diff --git a/tests/run-make/issue-14500/foo.rs b/tests/run-make/issue-14500/foo.rs
new file mode 100644
index 000000000..7c19c1f2c
--- /dev/null
+++ b/tests/run-make/issue-14500/foo.rs
@@ -0,0 +1,5 @@
+#[no_mangle]
+pub extern "C" fn foo() {}
+
+#[no_mangle]
+pub static FOO_STATIC: u8 = 0;