summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-18943
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-18943')
-rw-r--r--tests/run-make/issue-18943/Makefile7
-rw-r--r--tests/run-make/issue-18943/foo.rs5
2 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/issue-18943/Makefile b/tests/run-make/issue-18943/Makefile
new file mode 100644
index 000000000..fc40d756d
--- /dev/null
+++ b/tests/run-make/issue-18943/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+# Regression test for ICE #18943 when compiling as lib
+
+all:
+ $(RUSTC) foo.rs --crate-type lib
+ $(call REMOVE_RLIBS,foo) && exit 0 || exit 1
diff --git a/tests/run-make/issue-18943/foo.rs b/tests/run-make/issue-18943/foo.rs
new file mode 100644
index 000000000..d18400dd3
--- /dev/null
+++ b/tests/run-make/issue-18943/foo.rs
@@ -0,0 +1,5 @@
+trait Foo { }
+
+trait Bar { }
+
+impl<'a> Foo for Bar + 'a { }