summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-37893
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-37893')
-rw-r--r--tests/run-make/issue-37893/Makefile5
-rw-r--r--tests/run-make/issue-37893/a.rs2
-rw-r--r--tests/run-make/issue-37893/b.rs2
-rw-r--r--tests/run-make/issue-37893/c.rs3
4 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/issue-37893/Makefile b/tests/run-make/issue-37893/Makefile
new file mode 100644
index 000000000..44e4a321a
--- /dev/null
+++ b/tests/run-make/issue-37893/Makefile
@@ -0,0 +1,5 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) a.rs && $(RUSTC) b.rs && $(RUSTC) c.rs
diff --git a/tests/run-make/issue-37893/a.rs b/tests/run-make/issue-37893/a.rs
new file mode 100644
index 000000000..b5dffac3f
--- /dev/null
+++ b/tests/run-make/issue-37893/a.rs
@@ -0,0 +1,2 @@
+#![allow(unused)]
+#![crate_type = "proc-macro"]
diff --git a/tests/run-make/issue-37893/b.rs b/tests/run-make/issue-37893/b.rs
new file mode 100644
index 000000000..355d2b165
--- /dev/null
+++ b/tests/run-make/issue-37893/b.rs
@@ -0,0 +1,2 @@
+#![crate_type = "lib"]
+#[macro_use] extern crate a;
diff --git a/tests/run-make/issue-37893/c.rs b/tests/run-make/issue-37893/c.rs
new file mode 100644
index 000000000..b9c215572
--- /dev/null
+++ b/tests/run-make/issue-37893/c.rs
@@ -0,0 +1,3 @@
+#![crate_type = "staticlib"]
+extern crate b;
+extern crate a;