summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-53964
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-53964')
-rw-r--r--tests/run-make/issue-53964/Makefile5
-rw-r--r--tests/run-make/issue-53964/app.rs8
-rw-r--r--tests/run-make/issue-53964/panic.rs10
3 files changed, 23 insertions, 0 deletions
diff --git a/tests/run-make/issue-53964/Makefile b/tests/run-make/issue-53964/Makefile
new file mode 100644
index 000000000..6bd830213
--- /dev/null
+++ b/tests/run-make/issue-53964/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) panic.rs
+ $(RUSTC) -C panic=abort --emit=obj app.rs -L $(TMPDIR)
diff --git a/tests/run-make/issue-53964/app.rs b/tests/run-make/issue-53964/app.rs
new file mode 100644
index 000000000..8127b9578
--- /dev/null
+++ b/tests/run-make/issue-53964/app.rs
@@ -0,0 +1,8 @@
+#![crate_type = "bin"]
+#![no_main]
+#![no_std]
+
+#![deny(unused_extern_crates)]
+
+// `panic` provides a `panic_handler` so it shouldn't trip the `unused_extern_crates` lint
+extern crate panic;
diff --git a/tests/run-make/issue-53964/panic.rs b/tests/run-make/issue-53964/panic.rs
new file mode 100644
index 000000000..a87812050
--- /dev/null
+++ b/tests/run-make/issue-53964/panic.rs
@@ -0,0 +1,10 @@
+#![crate_type = "lib"]
+#![feature(panic_handler)]
+#![no_std]
+
+use core::panic::PanicInfo;
+
+#[panic_handler]
+fn panic(_: &PanicInfo) -> ! {
+ loop {}
+}