summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-71519
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-71519')
-rw-r--r--tests/run-make/issue-71519/Makefile8
-rw-r--r--tests/run-make/issue-71519/main.rs4
2 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/issue-71519/Makefile b/tests/run-make/issue-71519/Makefile
new file mode 100644
index 000000000..57497f520
--- /dev/null
+++ b/tests/run-make/issue-71519/Makefile
@@ -0,0 +1,8 @@
+include ../../run-make-fulldeps/tools.mk
+
+# ignore-msvc
+# needs-rust-lld
+# ignore-s390x lld does not yet support s390x as target
+all:
+ RUSTC_LOG=rustc_codegen_ssa::back::link=info $(RUSTC) -Z gcc-ld=lld -C link-args=-Wl,-v main.rs 2> $(TMPDIR)/output.txt
+ $(CGREP) -e "^LLD [0-9]+\.[0-9]+\.[0-9]+" < $(TMPDIR)/output.txt
diff --git a/tests/run-make/issue-71519/main.rs b/tests/run-make/issue-71519/main.rs
new file mode 100644
index 000000000..f8d09e897
--- /dev/null
+++ b/tests/run-make/issue-71519/main.rs
@@ -0,0 +1,4 @@
+// test linking using cc with rust-lld injected into search path as ld
+// see rust-lang/rust#71519 for more info
+
+fn main() {}